#2512 Problem starting Flux (solved)

ttmrichter Tue 16 Feb 2016

% flux
sys::ArgErr: Key already mapped: Console
  fan.sys.Map.add (Map.java:150)
  flux::Commands.buildViewMenu (Commands.fan:124)
  fan.sys.List.each (List.java:588)
  flux::Commands.buildViewMenu (Commands.fan:121)
  flux::Commands.buildMenuBar (Commands.fan:55)
  fan.sys.FanObj.with (FanObj.java:164)
  fan.sys.FanObj.with (FanObj.java:155)
  flux::Commands.buildMenuBar (Commands.fan:52)
  flux::Frame.make$ (Frame.fan:234)
  flux::Frame.make (Frame.fan:229)
  flux::Main.main (Main.fan:24)
  java.lang.reflect.Method.invoke (Method.java:497)
  fan.sys.Method.invoke (Method.java:559)
  fan.sys.Method$MethodFunc.callList (Method.java:198)
  fan.sys.Method.callList (Method.java:138)
  fanx.tools.Fan.callMain (Fan.java:173)
  fanx.tools.Fan.executeType (Fan.java:140)
  fanx.tools.Fan.execute (Fan.java:41)
  fanx.tools.Fan.run (Fan.java:298)
  fanx.tools.Fan.main (Fan.java:336)

% fan -version
Fantom Launcher
Copyright (c) 2006-2013, Brian Frank and Andy Frank
Licensed under the Academic Free License version 3.0

Java Runtime:
  java.version:    1.8.0_66
  java.vm.name:    Java HotSpot(TM) 64-Bit Server VM
  java.vm.vendor:  Oracle Corporation
  java.vm.version: 25.66-b17
  java.home:       /usr/local/jdk1.8.0_66/jre
  fan.platform:    linux-x86_64
  fan.version:     1.0.67
  fan.env:         util::PathEnv
  fan.home:        /home/michael/software/fantom-1.0.67

Env Path:
  /home/michael (work)
  /home/michael/software/fantom-1.0.67 (home)

I have no idea what it's trying to communicate to me with the "key already mapped" thing. Any idea where to go from here?

brian Tue 16 Feb 2016

It means you have multiple pods in your path which are registering the indexed key "flux.sideBar". Most likely you have a copy of flux and fluxText in both work and in home

ttmrichter Tue 16 Feb 2016

work? home?

I really have no idea what you're saying here, Brian, sorry. Explain as to a five year old: where should I look and what should I look for?

SlimerDude Tue 16 Feb 2016

Hi @ttmrichter,

sys::ArgErr: Key already mapped: Console

That's just a generic err msg from Map when using add() instead of set().

flux::Commands.buildViewMenu() collects Index Keys from pods. If the same key is added twice you'll get that error.

As you're using a FAN_ENV of util::PathEnv I imagine you have duplicate pods in both your Fantom home dir and your work dir. Probably flux.pod and / or fluxText/pod.

Compare the contents of:

  • /home/michael/software/fantom-1.0.67/lib/fan/ (Fantom home dir)
  • /home/michael/lib/fan/ (work dir)

ttmrichter Tue 16 Feb 2016

OK, I have fluxText.pod in both the software/fantom-1.0.67/lib/fan and in the lib/fan trees. Which should I get rid of (and how did I get them duplicated)?

I'm guessing (and it's purely a guess based on file dates) that the lib/fan version is a result of me using fanr install '*'. Is that correct?

SlimerDude Tue 16 Feb 2016

how did I get them duplicated

No idea - I didn't set up your computer! :)

I imagine they're both the same versions, so I'd delete all duplicate files in the /home/michael/lib/fan/ (work dir). The idea is that work dir is used as a scratch pad for your own stuff.

ttmrichter Tue 16 Feb 2016

OK, problem solved.

The mystery for me was why Flux failed on my laptop but succeeded on my Orange Pi PC. The difference is that fan.env was set to sys::BootEnv on the Orange Pi and sys::PathEnv on the laptop.

I was experimenting with Fanr and issued the command fanr install * on both platforms. On the Orange Pi this put everything into the already-existing directory tree and thus caused no trouble. On the laptop this put things into my $FAN_ENV_PATH (meaing /home/michael instead of /home/michael/software/fantom-1.0.67) and thus gave me duplicates of all the Fantom pods, which itself made flux vomit on startup.

Login or Signup to reply.