#2790 F4 IDE Error

small_petit Mon 4 May

Greetings to everyone. I am new to Fantom. I tried running a simple "Hello World" application in F4 IDE (1.1.2 or 1.1.4). However I keep getting this error:

WARN: cannot init Sys.curEnv

sys::UnknownPodErr: f4launchEnv

at fan.sys.UnknownPodErr.make(UnknownPodErr.java:25 at fan.sys.UnknownPodErr.make(UnknownPodErr.java:22 at fan.sys.Pod.readFPod(Pod.java:161) at fan.sys.Pod.doFind(Pod.java:67 at fan.sys.Pod.find(Pod.java:46)

ERROR: sys::UnknownPodErr: helloWorld

Please what could be the problem? Thank you.

SlimerDude Mon 4 May

Hi small_petit,

That will be a file permissions problem on the F4 installation (or the Fantom installation if you've set up a alternative Interpreter)

When you run an application with F4 it uses the f4launchEnv.pod to find the pods built by F4. But to do so, f4launchEnv.pod needs to be part of your Fantom environment. So F4 copies f4launchEnv.pod to FAN_HOME/lib/fan/ - if that file copy goes wrong (typically due to file permissions) then I would expect to see the error you're seeing.

Make sure the F4 installation directory (or the Fantom installation if you've set up a alternative Interpreter) has appropriate write permissions.

Note - to get around this issue in F4 1.1.4, f4launchEnv.pod should now be bundled with the default embedded interpreter - so I'm surprised you're still seeing this.

small_petit Mon 4 May

Hello SlimerDude

Having read your comment and the suggestions, I ran F4.exe as an administrator on Windows 10 pc. And I have no issues. It just runs fine without any problems.

Though, I don't understand why I have to run it as an administrator.

Thank you.

Login or Signup to reply.