#2850 [ANN] F4 v1.1.6 - Fantom IDE

SlimerDude Sat 17 Jul 2021

Binaries for the latest F4 v1.1.6 Fantom IDE release are now available on GitHub:

F4 v1.1.6 on GitHub


Main Features

F4 v1.1.6 main updates:

  • Dark Mode - now fully enabled! (I know you've ALL been waiting for this one!)
  • Internal Fantom compiler updated to Fantom 1.0.76 (from 1.0.74)
  • Embedded Fantom interpretter updated to Fantom 1.0.76 (from 1.0.74)

This update adds a Default option to the Fantom Syntax Coloring settings, allowing the colour of ALL the text in Fantom editors to be updated.

The default eclipse colours for Dark Mode are pretty poor, but are easy enough to change. For example, my own colours are based on the EMACS Doom Vibrant Theme:

F4 Dark Mode

Bug Fixes

F4 v1.1.6 also fixes some long standing bugs:

  • 22 - Launch class browse button does not work in launch config dialog
  • 39 - Operator functions return wrong type (for autocomplete)
  • 70 - Type.make() does not appear in autocomplete
  • 72 - Caught Errs are not recognised
  • 86 - Return type of function fields are not recognised
  • 92 - Extending from classes with the same name
  • 104 - F4 doesn't recognise return types from function fields
  • 108 - F4 Update site is out of date
  • 122 - Project versions not recognised

Essential Plugins

Have fun!

SlimerDude Tue 19 Oct 2021

The default eclipse / F4 colours for Dark Mode are pretty poor - so I thought I'd post this GIST of the F4 colours that I use.

Doom Vibrant Theme (Dark) for Fantom F4 IDE

F4 Dark Mode

Alex Bible Tue 19 Oct 2021

+1 This is great. I can finally use dark mode again :-)

Wesley Wed 20 Oct 2021

Awesome! My eyes can finally rest again. Thanks Steve!

SlimerDude Sat 23 Oct 2021

Continuing the dark theme, skewty donated the following based on the Darkula theme for JetBrains.

Darkula Theme (Dark) for Fantom F4 IDE

Darkula Theme

Now you have a choice!

Kevin Mon 7 Feb 2022

Hi Slimer!

Thanks for all your hard work!

I'm currently using a MacBook Air M1 Apple Silicon and I'm having problems getting F4 to run. The native code stub is not being recognized as executable code, regardless of what I do. Rosetta 2 has been installed, so it should just transcode and go, but so far, no go. I tried sneaking in the stub from the latest version of Eclipse, but it called me a bad, bad person.

If I knew which JAR file to launch, I could just launch F4 manually or, normally, this stub is a shell script, which I can whip up and use instead. Can you helpa poor programmer out here?

SlimerDude Wed 9 Feb 2022

Hi Kevin,

I'm afraid I don't use a Mac, so I'm not much help here.

I do know others have successfully used F4 on a Mac, but I couldn't tell you what Mac set up they have.

As for starting F4 / eclipse, there does seem to be a launch .jar - the details of which are in f4.ini; but I wouldn't know how to go about launching it manually.



Kevin Thu 10 Feb 2022

Thanks for the reply. Unfortunately, the launch stub shows as a document (text file) instead of as a Unix executable, so refuses to run. I removed the quarantine, but that was no help. I also tried directly launching the launcher file specified in the F4.ini. It fails silently--I don't even see an error in the console.

It works fine on my older Intel Mac, but I'm in the midst of migration and am trying to go all-in on the ARM and I only have a couple of miscreant programs I can't get to run.

I looked for F4 on the Eclipse Marketplace, but it just stared at me blankly. Is there a repository URL that I can use to install the needed Fantom components?

Also, as an aside, I noticed that F4 is a total memory pig with the max set to 1GB. Is there any reason why I can't drop that down to 512Mb or even less? The min is set to 256Mb. I generally have tons open and I try to avoid using any virtual memory if I can.

Login or Signup to reply.