#2891 Something wrong with method call?

SlimerDude Sat 24 Jun 2023

Hi, When trying to compile a simple class to call the ODF Toolkit 0.11.0 Java lib, I receive this error:

$ fan build.fan

compile [acmeOdf]
  Compile [acmeOdf]
    FindSourceFiles [1 files]
C:\Acme\fan\OdfTest.fan(5,26): Something wrong with method call?

The source code:

using [java] org.odftoolkit.odfdom.doc::OdfTextDocument

class OdfTest {
  Void newDoc() {
    odt := OdfTextDocument.newTextDocument()


The method I'm trying to call is documented here: OdfTextDocument.newTextDocument().

The ODF Toolkit release notes mentions that the library uses JDK 11; which my environment should cater for.

$ fan -version

Fantom Launcher
Copyright (c) 2006-2021, Brian Frank and Andy Frank
Licensed under the Academic Free License version 3.0

Java Runtime:
  java.version:    11.0.19
  java.vm.name:    OpenJDK 64-Bit Server VM
  java.vm.vendor:  Eclipse Adoptium
  java.vm.version: 11.0.19+7
  java.home:       C:\Apps\Java\jdk-11.0.19+7
  fan.platform:    win32-x86_64
  fan.version:     1.0.78
  fan.env:         sys::BootEnv
  fan.home:        C:\fantom-1.0.78

I've also tried running the fantom build with JDK-14 just to make sure - but I receive the same error.

Is there something else I'm missing?

Note the java src for the offending method looks pretty innocuous:

 * Creates an empty text document.
 * @return ODF text document based on a default template
 * @throws java.lang.Exception - if the document could not be created
public static OdfTextDocument newTextDocument() throws Exception {
  return (OdfTextDocument)
      OdfDocument.loadTemplate(EMPTY_TEXT_DOCUMENT_RESOURCE, OdfDocument.OdfMediaType.TEXT);

Login or Signup to reply.