#515 Cant access the mercurial repository

wangzaixiang Wed 8 Apr 2009

I want to checkout the source code using the follow command:

hg clone http://hg.fandev.org/repos/fan-1.0

and it always display the following message:

requesting all changes
adding changesets
adding manifests
transaction abort!
rollback completed
abort: connection ended unexpectedly

I am using the Mercurial Distributed SCM (version 1.2.1), can someone tell me what is the problem?

brian Wed 8 Apr 2009

Some people have had trouble using TortoiseHG, but find the command line works.

I am using 1.0.2 on my machine and it worked ok (I am pretty sure newer hg versions work with older repos). But I assume my IP route is a lot closer to the server than yours, so I would be less likely to have network timeouts.

If you want I can email you the repo to get started.

f00biebletch Wed 8 Apr 2009

I checked the server, we are running 1.0.1 for hg, so there may be a version incompatibility issue. Could you try running an older version of hg? I am running a test client with 1.1.2 and clone reliably.

I will upgrade the server at some point in the near future, but it would be good to isolate the issue first.

qualidafial Wed 8 Apr 2009

I had this same problem, where I couldn't pull changes into an existing repository (with my own changes, not sure if this had any effect). What I did that worked was to do a fresh clone of the repository to another folder on my computer, then pulled the changes from that fresh clone into my existing clone.

wangzaixiang Wed 8 Apr 2009

Thanks, brian, please email to wangzaixiang@gmail.com.

wangzaixiang Wed 8 Apr 2009

I am now using the Mercurial Distributed SCM (version 1.1.2+20090302), and still the same problem.

wangzaixiang Thu 9 Apr 2009

Thanks for brian's email, I have got the reposity and checkout a workcopy successfully.

But now, i using hg to pull following changset and got an error:

E:\java\fan-repository>"d:\Program Files\Mercurial\hg1.1.2\hg.exe" pull http://h
abort: requirement '<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//E
N">' not supported!

I using both the hg 1.1.2 and 1.2.1, both of them have the same problem.

alexlamsl Thu 9 Apr 2009

Should be http://hg.fandev.org/repos/fan-1.0 (repos rather than repo), I think.

(By the way, how do I just bold say the letter s in a word, e.g. repos?)

f00biebletch Thu 9 Apr 2009


"d:\Program Files\Mercurial\hg1.1.2\hg.exe" pull http://hg.fandev.org/repos/fan-1.0

DanielFath Fri 6 Nov 2009

Has this problem been solved?

I have similar issue with Mercurial 1.3.1 (I have tried clone/pull but both report same error).

andy Fri 6 Nov 2009

Not sure what the problem is - but I posted a bundle from today - might try starting with that, and see if you can pull ok from there:


DanielFath Fri 6 Nov 2009

Thanks, seems to be working for now. But in future you might want to check that.

StephenViles Fri 3 Feb 2012

I've encountered this problem as well, but I found a workaround: clone the first 1000 revisions, then pull groups of revisions until you eventually have the whole repository.

The problem:

$ hg --version | head -1
Mercurial Distributed SCM (version 1.9.3)
$ hg clone http://hg.fantom.org/repos/fan-1.0
real URL is http://hg.fantom.org/fan-1.0
requesting all changes
adding changesets
adding manifests
adding file changes
transaction abort!
rollback completed
abort: connection ended unexpectedly

Here's the workaround (with -q to suppress non-error output). I found the sequence of revisions through trial and error. If you get an abort message, simply reduce the number of revisions in the pull command.

$ hg clone -q -r 1000 http://hg.fantom.org/repos/fan-1.0
$ cd fan-1.0
$ hg pull -q -r 1500 -u
$ hg pull -q -r 1700 -u
$ hg pull -q -r 2000 -u
$ hg pull -q -r 3000 -u
$ hg pull -u
real URL is http://hg.fantom.org/fan-1.0
pulling from http://hg.fantom.org/repos/fan-1.0
searching for changes
adding changesets
adding manifests
adding file changes
added 607 changesets with 1993 changes to 790 files
766 files updated, 0 files merged, 70 files removed, 0 files unresolved

mg30rg Wed 6 Mar 2013

I had the same symptoms but an other problem:

I am working behind a proxy and the mercurial installation did not add the proxy address to the mercurial.ini file, which can be found in users/username on Win7 (I'm pretty sure that it is a system path, but I will not waste my time searching for the appropriate macro).

Modifying this file like adding: [http_proxy] host = YourHTTPProxyAddress Worked for me.

Login or Signup to reply.