#925 Couple API renames

brian Thu 21 Jan 2010

Now that Obj.type is renamed to typeof, I think it might make sense to rename these APIs:

Field.of   =>  Field.type
Param.of   =>  Param.type
Symbol.of  =>  Symbol.type

Comments?

lbertrand Thu 21 Jan 2010

+1 make sense

DanielFath Thu 21 Jan 2010

+1. Though wouldn't it be more consistent to use typeof?

brian Thu 21 Jan 2010

Though wouldn't it be more consistent to use typeof?

Field.typeof is Field#, this is the method to get the field's type.

tactics Thu 21 Jan 2010

What about List.of?

brian Thu 21 Jan 2010

What about List.of?

I still think that method if still correct, because it the type of the items we care about. In fact that was one of the things I disliked about using of for Field,Param was that it was slightly inconsistent with List.of.

Login or Signup to reply.